中危 由于部分 CVE-2022-31629 修复 (CVE-2024-2756),__Host-/__Secure- cookie 绕过

CVE编号

CVE-2024-2756

利用情况

暂无

补丁情况

官方补丁

披露时间

2024-04-29
漏洞描述
由于对CVE-2022-31629的修复不完全,攻击者可以在受害者浏览器中设置一个标准的不安全Cookie,该Cookie被PHP应用程序视为__Host-或__Secure- Cookie,从而导致网络和同站攻击。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
系统 alpine_3.19 php81 * Up to
(excluding)
8.3.6-r0
运行在以下环境
系统 debian_11 php7.4 * Up to
(excluding)
7.4.33-1+deb11u5
运行在以下环境
系统 debian_12 php8.2 * Up to
(excluding)
8.2.18-1~deb12u1
运行在以下环境
系统 fedora_38 php * Up to
(excluding)
8.2.18-1.fc38
运行在以下环境
系统 fedora_39 php * Up to
(excluding)
8.2.18-1.fc39
运行在以下环境
系统 fedora_40 php * Up to
(excluding)
8.3.6-1.fc40
运行在以下环境
系统 opensuse_Leap_15.5 php8 * Up to
(excluding)
8.0.30-150400.4.40.1
阿里云评分
6.1
  • 攻击路径
    本地
  • 攻击复杂度
    困难
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
阿里云安全产品覆盖情况